Code For Alls..!

get the code!!

Friday, 15 September 2017

Day 3: Intro to Conditional Statements-hackerrank-solution

                              Day 3: Intro to Conditional Statements-hackerrank-solution


Task
Given an integer, , perform the following conditional actions:
  • If  is odd, print Weird
  • If  is even and in the inclusive range of  to , print Not Weird
  • If  is even and in the inclusive range of  to , print Weird
  • If  is even and greater than , print Not Weird
Complete the stub code provided in your editor to print whether or not  is weird.
Input Format
A single line containing a positive integer, .
Constraints
  •  1<=n<=100
Output Format
Print Weird if the number is weird; otherwise, print Not Weird.
Sample Input 0
3
Sample Output 0
Weird
Sample Input 1
24
Sample Output 1
Not Weird
Explanation
Sample Case 0:
 is odd and odd numbers are weird, so we print Weird.
Sample Case 1:
 and  is even, so it isn't weird. Thus, we print Not Weird.

C program:
#include <math.h>
#include <stdio.h>
int main(){
    int N; 
    scanf("%d",&N);
    if(N%2!=0)
        printf("Weird");
    else
        {
        if(2<N&&N<5)
          printf("Not Weird");   
        else 
        {
            if(6<N&&N<=20)
            printf("Weird");
            else
             printf("Not Weird");
    }
    }
    
    return 0;

}


4 comments:



  1. Thanks for providing good information,Thanks for your sharing python Online Course

    ReplyDelete
  2. (N%2==0)?(N>=2 && N<=5)?(printf("Not Weird")):(N>=6 && N<=20)?printf("Weird"):printf("Not Weird"):printf("Weird");

    ONLY ABOVE CODE OF LINE SOLVES THE PROBLEM :)

    ReplyDelete