Two cats named and are standing at integral points on the x-axis. Cat is standing at point and cat is standing at point . Both cats run at the same speed, and they want to catch a mouse named that's hiding at integral point on the x-axis. Can you determine who will catch the mouse?
You are given queries in the form of , , and . For each query, print the appropriate answer on a new line:
You are given queries in the form of , , and . For each query, print the appropriate answer on a new line:
- If cat catches the mouse first, print
Cat A
. - If cat catches the mouse first, print
Cat B
. - If both cats reach the mouse at the same time, print
Mouse C
as the two cats fight and mouse escapes.
Input Format
The first line contains a single integer, , denoting the number of queries.
Each of the subsequent lines contains three space-separated integers describing the respective values of (cat 's location), (cat 's location), and (mouse 's location).
Each of the subsequent lines contains three space-separated integers describing the respective values of (cat 's location), (cat 's location), and (mouse 's location).
Constraints
Output Format
On a new line for each query, print
Cat A
if cat catches the mouse first, Cat B
if cat catches the mouse first, or Mouse C
if the mouse escapes.
Sample Input 0
3
1 2 3
1 3 2
2 1 3
Sample Output 0
Cat B
Mouse C
Cat A
Explanation 0
Query 0: The positions of the cats and mouse are shown below:
Cat will catch the mouse first, so we print
Query 1: In this query, cats and reach mouse at the exact same time:
Because the mouse escapes, we print
C-code:
#include <math.h>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <assert.h>
#include <limits.h>
#include <stdbool.h>
int main(){
int q;
scanf("%d",&q);
for(int a0 = 0; a0 < q; a0++){
int x,y,z;
scanf("%d %d %d",&x,&y,&z);
if(abs(z-x)<abs(z-y))
printf("Cat A\n");
else if(abs(z-x)>abs(z-y))
printf("Cat B\n");
else
printf("Mouse C\n");
}
return 0;
}
Cat will catch the mouse first, so we print
Cat B
on a new line.Query 1: In this query, cats and reach mouse at the exact same time:
Because the mouse escapes, we print
Mouse C
on a new line.C-code:
#include <math.h>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <assert.h>
#include <limits.h>
#include <stdbool.h>
int main(){
int q;
scanf("%d",&q);
for(int a0 = 0; a0 < q; a0++){
int x,y,z;
scanf("%d %d %d",&x,&y,&z);
if(abs(z-x)<abs(z-y))
printf("Cat A\n");
else if(abs(z-x)>abs(z-y))
printf("Cat B\n");
else
printf("Mouse C\n");
}
return 0;
}
No comments:
Post a Comment